Linux Mind Italia

  • Venerdì 18 Ottobre 2019, 03:01:52
  • Benvenuto, Visitatore
Effettua l'accesso o una nuova registrazione.

Inserisci il nome utente, la password e la durata della sessione.
Ricerca avanzata

News:

Dopo oltre 4 anni di sviluppo, rilasciato XFCE 4.14 < annuncio >  < discussione >

collapse

* Canale Telegram

Canale informativo di riserva:
Linuxminditalia
https://t.me/linuxmind

* Mind-chat

Refresh History
  • bobol: :ciao:  orsù dunque
    Mercoledì 16 Ottobre 2019, 17:15:13
  • Cavaleri Omar: Ehilà!!!
    Mercoledì 16 Ottobre 2019, 07:54:54
  • bobol: :mago:
    Lunedì 14 Ottobre 2019, 22:24:01
  • bobol: :ciao:
    Lunedì 14 Ottobre 2019, 06:53:31
  • bobol: Ciao Dani bentrovato  :ciao:
    Sabato 12 Ottobre 2019, 08:40:07
  • bobol: Qualche respiro lo tiriamo ancora...... :) Quando al login avrai il messaggio 404 allora puoi andare a prendere un mazzetto di fiori  ;D
    Sabato 12 Ottobre 2019, 08:38:48
  • danialbi: un saluto a tutti. sono di passaggio, c'e' ancora vita qui?
    Sabato 12 Ottobre 2019, 01:05:49
  • cuzzo: bau
    Venerdì 11 Ottobre 2019, 11:14:12
  • cuzzo: noche
    Giovedì 10 Ottobre 2019, 22:38:42
  • cuzzo: aloa
    Giovedì 10 Ottobre 2019, 20:11:56
  • JonnyBarbun87: Ciao a tutti, ragazzi :D
    Giovedì 10 Ottobre 2019, 15:20:47
  • bobol: :ciao:
    Giovedì 10 Ottobre 2019, 11:35:24
  • bobol: :coffee:
    Martedì 08 Ottobre 2019, 06:07:59
  • TheBaron: :ciao:
    Domenica 06 Ottobre 2019, 01:23:07
  • cuzzo: aloa
    Venerdì 04 Ottobre 2019, 11:42:36
  • bobol: :ciao: ciao Roby puoi passare nella sezione presentazioni per un saluto generale a tutti gli utenti  ;)
    Venerdì 04 Ottobre 2019, 11:18:19
  • Roby: ciao a tutti
    Martedì 01 Ottobre 2019, 21:58:02
  • bobol: :ciao: buondì
    Martedì 01 Ottobre 2019, 06:59:22
  • bobol: :ciao:
    Domenica 29 Settembre 2019, 15:03:46
  • Tony: :ciao:
    Domenica 29 Settembre 2019, 13:35:26
  • mortaretto: buona domeniica pinguini  :ciao:
    Domenica 29 Settembre 2019, 12:41:51
  • bobol: buona domenica  :ciao:
    Domenica 29 Settembre 2019, 09:19:22
  • Tony: :coffee:
    Domenica 29 Settembre 2019, 07:26:02
  • bobol: :coffee:
    Sabato 28 Settembre 2019, 08:57:05
  • bobol: :ciao:
    Giovedì 26 Settembre 2019, 18:25:12
  • bobol: ;)
    Mercoledì 25 Settembre 2019, 11:47:23
  • Cavaleri Omar: Buondì...
    Mercoledì 25 Settembre 2019, 10:14:41
  • bobol: Come ieri ma...nebbioso.... :coffee:
    Martedì 24 Settembre 2019, 06:47:46
  • bobol: Buonanotte  :)
    Lunedì 23 Settembre 2019, 22:03:09
  • bobol: ...e buonasera  :ciao:
    Lunedì 23 Settembre 2019, 17:12:39

* Utenti On Line

  • Dot Visitatori: 29
  • Dot Nascosti: 0
  • Dot Utenti: 0

There aren't any users online.

Autore Topic: Problema installazione HpLip [RISOLTO]  (Letto 122 volte)

scuianut

  • New Mind
  • *
  • Offline Offline
  • Post: 17
  • Distro: Mint 19.2-64 Cinnamon
  • Det här är bara en dröm, och snart vaknar jag
Problema installazione HpLip [RISOLTO]
« il: Giovedì 12 Settembre 2019, 06:09:46 »

Buongiorno a tutti,
sono il felice possessore di una stampante multifunzione di rete HP MFP M477 ed ho qualche piccolo problema nell'installarla e configurarla correttamente in Mint 19.2C.
Con precedenti versioni di Mint avevo scaricato ed installato il programma HpLip, che mi consentiva di utilizzare stampante, scanner e varie funzioni avanzate.
In Mint 19.2 e' gia' presente a sistema la versione 3.17.10 quindi se accendo la stampante, viene visualizzata automaticamente nell'elenco delle stampanti.
Visto che pero' il driver e' piuttosto "basic" e non riesco a sfruttare bene il dispositivo, ho voluto installare il pacchetto 3.19.8 dal sito, pero' a causa di un problema nelle dipendenze non riesco ad andare avanti.
Leggendo varie guide qua e la' sono solo riuscito ad avere due stampanti (una scompare quando la spengo) ma la versione di HpLip e' comunque sempre la stessa.
Ho tentato di installare le dipendenze manualmente ma ci deve essere qualcosa che va in conflitto e l'installazione si ferma sempre nello stesso punto.
Qualcuno puo' aiutarmi?
Allego parte della procedura di installazione di HpLip.
Grazie mille in anticipo
Codice: [Seleziona]
DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Linux Mint 19.2.

Is "Linux Mint 19.2" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y

Initializing. Please wait...


INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information.  Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit:


SECURITY PACKAGES
-----------------
AppArmor is installed.
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ?


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
libcrypto            network              REQUIRED           
libnetsnmp-devel     network              REQUIRED           
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? y


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo apt-get update (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo DEBIAN_FRONTEND=noninteractive apt-get --assume-yes install openssl'
Please wait, this may take several minutes...
Running 'sudo DEBIAN_FRONTEND=noninteractive apt-get --assume-yes install libsnmp-dev'
Please wait, this may take several minutes...
error: Install command failed with error code 100
« Ultima modifica: Venerdì 13 Settembre 2019, 06:38:11 da scuianut »
Connesso

Tony

  • Staff
  • Hero Mind
  • ******
  • Offline Offline
  • Post: 3907
  • Distro: Ubuntu 18.04.1 LTS 64bit XFCE
Re:Problema installazione HpLip
« Risposta #1 il: Giovedì 12 Settembre 2019, 07:12:50 »

Prova ad installare a manina le dipendenze.
Codice: [Seleziona]
sudo apt-get install openssl libsnmp-dev
Poi ripeti l'installazione di hplip.
Connesso
Linux non è solo un sistema operativo ma...
"È uno stato mentale, dove prima ti perdi e poi ti ritrovi"
(cit. Point Break).

scuianut

  • New Mind
  • *
  • Offline Offline
  • Post: 17
  • Distro: Mint 19.2-64 Cinnamon
  • Det här är bara en dröm, och snart vaknar jag
Re:Problema installazione HpLip
« Risposta #2 il: Giovedì 12 Settembre 2019, 11:50:19 »

Grazie Tony,
purtroppo pero' non funge
Codice: [Seleziona]
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
openssl è già alla versione più recente (1.1.1-1ubuntu2.1~18.04.4).
Alcuni pacchetti non possono essere installati. Questo puo' voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 libsnmp-dev : Dipende: libsnmp30 (= 5.7.3+dfsg-1.8ubuntu3.1) ma la versione 5.7.3+dfsg-1.8ubuntu3.2 sta per essere installata
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
Il messaggio non e' chiarissimo ma mi sembra come se ci fosse qualcosa che blocca l'installazione del pacchetto  :hmm:
Purtroppo ne' Mint ne' HpLip risolvono automaticamente questa cosa.
Ho provato anche con sudo apt-get -f install
Codice: [Seleziona]
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libgl1-mesa-glx:i386 libxinerama1:i386 node-normalize.css
Usare "sudo apt autoremove" per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 23 non aggiornati.
ma non sembrano esserci novita'
Ci sono proposte?
Grazie mille
Connesso

andrea111

  • Sr. Mind
  • ****
  • Offline Offline
  • Post: 1011
  • Distro: ubuntu 16.04
Re:Problema installazione HpLip
« Risposta #3 il: Giovedì 12 Settembre 2019, 13:25:31 »

Prova a postare
Codice: [Seleziona]
sudo dpkg -l libsnmp-devvediamo se hai installato una qualche versione del pacchetto in questione oppure ti manca del tutto.
Connesso
Portatile ASUS con Scheda madre X55C +i5-3210M -- 6 GB RAM ddr3 -- grafica intel.

scuianut

  • New Mind
  • *
  • Offline Offline
  • Post: 17
  • Distro: Mint 19.2-64 Cinnamon
  • Det här är bara en dröm, och snart vaknar jag
Re:Problema installazione HpLip
« Risposta #4 il: Giovedì 12 Settembre 2019, 21:37:21 »

Ciao Andrea e grazie per il tuo aiuto,
con quel comando mi viene fuori questo:
Codice: [Seleziona]
Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H (in attesa)
| Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err: maiuscolo=grave)
||/ Nome           Versione     Architettura Descrizione
+++-==============-============-============-=================================
un  libsnmp-dev    <nessuna>    <nessuna>    (nessuna descrizione disponibile)
daniele@daniele-H110M-S2H-DDR3:~$
Non so interpretare purtroppo, il componente sembra non esserci (probabilmente per un conflitto non risolto)
Grazie comunque
Connesso

andrea111

  • Sr. Mind
  • ****
  • Offline Offline
  • Post: 1011
  • Distro: ubuntu 16.04
Re:Problema installazione HpLip
« Risposta #5 il: Giovedì 12 Settembre 2019, 22:56:21 »

libsnmp-dev è un pacchetto di cui hplip necessita, una sua dipendenza ha però una differente versione.

Prova ad installarlo
Codice: [Seleziona]
sudo apt install libsnmp-dev fai una prova di stampa e vedi se lo accetta.
Il problema non sta nel pacchetto libsnmp-dev, ma di una sua dipendenza.
Installandolo può essere che si risolva.
Connesso
Portatile ASUS con Scheda madre X55C +i5-3210M -- 6 GB RAM ddr3 -- grafica intel.

scuianut

  • New Mind
  • *
  • Offline Offline
  • Post: 17
  • Distro: Mint 19.2-64 Cinnamon
  • Det här är bara en dröm, och snart vaknar jag
Re:Problema installazione HpLip
« Risposta #6 il: Venerdì 13 Settembre 2019, 06:35:18 »

Installato pacchetto manually come da tuo suggerimento Andrea, poi ho ripetuto l'installazione di HPLip (con relativo plugin) e ....

FUNZIONAAAAAA!!
Grazie mille
 :)  :hs:
Connesso