Linux Mind Italia

Supporto hardware e software => Script, Guide, HowTo e FAQ => Programmazione: Python, C++ ... => Topic aperto da: petrusic - Mercoledì 18 Settembre 2019, 12:24:21

Titolo: [Risolto] perchè non posso reinstallare gambas?
Inserito da: petrusic - Mercoledì 18 Settembre 2019, 12:24:21
Recentemente ho fatto diverse prove con installazioni di S.O. , ragion per cui ho sovrascritto la mia precedente installazione di Linux Mint.
Non sto a raccontarvi le mie esperienze vissute fino ad oggi, ma vorrei strutturare un ambiente in cui posso fare convivere Java con Eclipse e Gambas3, con cui ho realizzato un'applicazione che utilizzo tutti i giorni.
Le distro con cui mi sono trovato bene nel recente passato sono Linux Mint, fedora e, da poco, Lubuntu.
Ho perciò suddiviso il disco dei S.O. in 3 partizioni, dove ho installato Linux Mint mate 19, Lubuntu 19.04 e fedora 30 LXQT.
Proprio stamattina ho finito di reinstallare Linux Mint e, dopo i primi passi di configurazione, ho avviato l'installazione di gambas3,
prima con:
Codice: [Seleziona]
udo apt install gambas3
[sudo] password di petrus:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto gambas3

poi con:
Codice: [Seleziona]
sudo add-apt-repository ppa:gambas-team/gambas3
Stai per aggiungere il seguente PPA:
 Maggiori informazioni: https://launchpad.net/~gambas-team/+archive/ubuntu/gambas3
Premi Invio per continuare o Ctrl+C per annullare

Executing: /tmp/apt-key-gpghome.uguCusogoX/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 6CAEE58D
gpg: key 50B027516CAEE58D: 1 signature not checked due to a missing key
gpg: chiave 50B027516CAEE58D: chiave pubblica "Launchpad PPA for Gambas Ubuntu Maintainers" importata
gpg: Numero totale esaminato: 1
gpg:               importate: 1
petrus@petrus-Aspire-M1200-3200-5200:~$ sudo apt-get install gambas3 -y
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto gambas3

É una sorpresa che non m'aspettavo, proprio perchè nella precedente installazione della stessa versione di Linux Mint, avevo già installato gambas.

Esiste un altro percorso da seguire per riuscire ad installare gambas3?
Titolo: Re:perchè non posso reinstallare gambas?
Inserito da: andrea111 - Mercoledì 18 Settembre 2019, 13:52:30
Citazione
É una sorpresa che non m'aspettavo,
Dopo aver installato il ppa devi (obbligatoriamente) dare il
Codice: [Seleziona]
sudo apt update altrimenti i repo non si aggiornano con i nuovi pacchetti del ppa. Dopo aver dato l'update puoi dare il comando per installare gambas3.
Titolo: Re:perchè non posso reinstallare gambas?
Inserito da: petrusic - Mercoledì 18 Settembre 2019, 15:10:50
Dopo aver installato il ppa devi (obbligatoriamente) dare il
Codice: [Seleziona]
sudo apt update altrimenti i repo non si aggiornano con i nuovi pacchetti del ppa. Dopo aver dato l'update puoi dare il comando per installare gambas3.
Ho fatto proprio come dici tu. Ecco perchè è stata una sorpresa.
Titolo: Re:perchè non posso reinstallare gambas?
Inserito da: evilwillneverdie - Mercoledì 18 Settembre 2019, 18:34:43
Io ho provato ad installarlo su 18.04.3 e si installa...  :hmm:
Titolo: Re:perchè non posso reinstallare gambas?
Inserito da: andrea111 - Mercoledì 18 Settembre 2019, 20:32:10
C'è qualche motivo che ti fa adottare una non LTS? (la 19.04)
Vengono supportate solo per sei mesi contro i cinque anni delle LTS (18.04 e la prossima sarà la 20.04)

Prova a vedere che dice 
Codice: [Seleziona]
apt-cache search gambas*Potrebbe essere che nemmeno c'è il pacchetto per la 19.04
Titolo: Re:perchè non posso reinstallare gambas?
Inserito da: petrusic - Mercoledì 18 Settembre 2019, 23:28:46
C'è qualche motivo che ti fa adottare una non LTS? (la 19.04)
Vengono supportate solo per sei mesi contro i cinque anni delle LTS (18.04 e la prossima sarà la 20.04)

Prova a vedere che dice 
Codice: [Seleziona]
apt-cache search gambas*Potrebbe essere che nemmeno c'è il pacchetto per la 19.04

Va bene. Aspetterò la 20.04. Grazie.